GHSA-vr8q-g5c7-m54m

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2020/12/GHSA-vr8q-g5c7-m54m/GHSA-vr8q-g5c7-m54m.json
Aliases
Published
2020-12-30T18:35:06Z
Modified
2022-09-20T03:29:04.455033Z
Details

Severity

Nokogiri maintainers have evaluated this as Low Severity (CVSS3 2.6).

Description

In Nokogiri versions <= 1.11.0.rc3, XML Schemas parsed by Nokogiri::XML::Schema are trusted by default, allowing external resources to be accessed over the network, potentially enabling XXE or SSRF attacks.

This behavior is counter to the security policy followed by Nokogiri maintainers, which is to treat all input as untrusted by default whenever possible.

Please note that this security fix was pushed into a new minor version, 1.11.x, rather than a patch release to the 1.10.x branch, because it is a breaking change for some schemas and the risk was assessed to be "Low Severity".

Affected Versions

Nokogiri <= 1.10.10 as well as prereleases 1.11.0.rc1, 1.11.0.rc2, and 1.11.0.rc3

Mitigation

There are no known workarounds for affected versions. Upgrade to Nokogiri 1.11.0.rc4 or later.

If, after upgrading to 1.11.0.rc4 or later, you wish to re-enable network access for resolution of external resources (i.e., return to the previous behavior):

  1. Ensure the input is trusted. Do not enable this option for untrusted input.
  2. When invoking the Nokogiri::XML::Schema constructor, pass as the second parameter an instance of Nokogiri::XML::ParseOptions with the NONET flag turned off.

So if your previous code was:

# in v1.11.0.rc3 and earlier, this call allows resources to be accessed over the network
# but in v1.11.0.rc4 and later, this call will disallow network access for external resources
schema = Nokogiri::XML::Schema.new(schema)

# in v1.11.0.rc4 and later, the following is equivalent to the code above
# (the second parameter is optional, and this demonstrates its default value)
schema = Nokogiri::XML::Schema.new(schema, Nokogiri::XML::ParseOptions::DEFAULT_SCHEMA)

Then you can add the second parameter to indicate that the input is trusted by changing it to:

# in v1.11.0.rc3 and earlier, this would raise an ArgumentError 
# but in v1.11.0.rc4 and later, this allows resources to be accessed over the network
schema = Nokogiri::XML::Schema.new(trusted_schema, Nokogiri::XML::ParseOptions.new.nononet)

References

Credit

This vulnerability was independently reported by @eric-therond and @gucki.

The Nokogiri maintainers would like to thank HackerOne for providing a secure, responsible mechanism for reporting, and for providing their fantastic service to us.

References

Affected packages

RubyGems / nokogiri

nokogiri

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
1.11.0

Affected versions

1.*

1.0.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.1.0
1.1.1
1.10.0
1.10.0.rc1
1.10.1
1.10.10
1.10.2
1.10.3
1.10.4
1.10.5
1.10.6
1.10.7
1.10.8
1.10.9
1.11.0.rc1
1.11.0.rc2
1.11.0.rc3
1.11.0.rc4
1.2.0
1.2.1
1.2.2
1.2.3
1.3.0
1.3.1
1.3.2
1.3.3
1.4.0
1.4.1
1.4.2
1.4.2.1
1.4.3
1.4.3.1
1.4.4
1.4.4.1
1.4.4.2
1.4.5
1.4.6
1.4.7
1.5.0
1.5.0.beta.1
1.5.0.beta.2
1.5.0.beta.3
1.5.0.beta.4
1.5.1
1.5.1.rc1
1.5.10
1.5.11
1.5.2
1.5.3
1.5.3.rc2
1.5.3.rc3
1.5.3.rc4
1.5.3.rc5
1.5.3.rc6
1.5.4
1.5.4.rc1
1.5.4.rc2
1.5.4.rc3
1.5.5
1.5.5.rc1
1.5.5.rc2
1.5.5.rc3
1.5.6
1.5.6.rc1
1.5.6.rc2
1.5.6.rc3
1.5.7
1.5.7.rc1
1.5.7.rc2
1.5.7.rc3
1.5.8
1.5.9
1.6.0
1.6.0.rc1
1.6.1
1.6.2
1.6.2.1
1.6.2.rc1
1.6.2.rc2
1.6.2.rc3
1.6.3
1.6.3.1
1.6.3.rc1
1.6.3.rc2
1.6.3.rc3
1.6.4
1.6.4.1
1.6.5
1.6.6.1
1.6.6.2
1.6.6.3
1.6.6.4
1.6.7
1.6.7.1
1.6.7.2
1.6.7.rc2
1.6.7.rc3
1.6.7.rc4
1.6.8
1.6.8.1
1.6.8.rc1
1.6.8.rc2
1.6.8.rc3
1.7.0
1.7.0.1
1.7.1
1.7.2
1.8.0
1.8.1
1.8.2
1.8.3
1.8.4
1.8.5
1.9.0
1.9.0.rc1
1.9.1

Database specific

{
    "last_known_affected_version_range": "<= 1.10.10"
}