GHSA-vrv8-v4w8-f95h

Suggest an improvement
Source
https://github.com/advisories/GHSA-vrv8-v4w8-f95h
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2020/08/GHSA-vrv8-v4w8-f95h/GHSA-vrv8-v4w8-f95h.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vrv8-v4w8-f95h
Aliases
Published
2020-08-11T14:55:01Z
Modified
2023-11-08T04:02:10.978052Z
Severity
  • CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Summary
Cross-site scripting vulnerability in TinyMCE
Details

Impact

A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.

Patches

This vulnerability has been patched in TinyMCE 4.9.11 and 5.4.1 by improved HTML parsing and sanitization logic.

Workarounds

The workarounds available are: - upgrade to either TinyMCE 4.9.11 or TinyMCE 5.4.1 or - enable the media plugin, which overrides the default parsing behaviour for iframes or - add the following workaround to update the parsing schema rules for iframes:

Example: Change the default schema for iframes

setup: function(editor) {
  editor.on('PreInit', function() {
    editor.schema.getSpecialElements()['iframe'] = /</iframe[^>]*>/gi;
  });
}

Acknowledgements

Tiny Technologies would like to thank George Steketee and Chris Davis at Bishop Fox for discovering this vulnerability.

References

https://www.tiny.cloud/docs/release-notes/release-notes54/#securityfixes

For more information

If you have any questions or comments about this advisory: * Open an issue in the TinyMCE repo * Email us at infosec@tiny.cloud

References

Affected packages

npm / tinymce

Package

Affected ranges

Type
SEMVER
Events
Introduced
0The exact introduced commit is unknown
Fixed
4.9.11

npm / tinymce

Package

Affected ranges

Type
SEMVER
Events
Introduced
5.0.0
Fixed
5.4.1