GHSA-vv4c-g6q7-p3q7

Suggest an improvement
Source
https://github.com/advisories/GHSA-vv4c-g6q7-p3q7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/03/GHSA-vv4c-g6q7-p3q7/GHSA-vv4c-g6q7-p3q7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vv4c-g6q7-p3q7
Aliases
Published
2019-03-25T16:15:54Z
Modified
2023-11-08T04:01:47.891295Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Doorkeeper-openid_connect contains Open Redirect
Details

Doorkeeper::OpenidConnect (aka the OpenID Connect extension for Doorkeeper) 1.4.x and 1.5.x before 1.5.4 has an open redirect via the redirect_uri field in an OAuth authorization request (that results in an error response) with the 'openid' scope and a prompt=none value. This allows phishing attacks against the authorization flow.

References

Affected packages

RubyGems / doorkeeper-openid_connect

Package

Name
doorkeeper-openid_connect
Purl
pkg:gem/doorkeeper-openid_connect

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.4.0
Fixed
1.5.4

Affected versions

1.*

1.4.0
1.5.0
1.5.1
1.5.2
1.5.3