GHSA-vv89-xggx-qqh2

Suggest an improvement
Source
https://github.com/advisories/GHSA-vv89-xggx-qqh2
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-vv89-xggx-qqh2/GHSA-vv89-xggx-qqh2.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vv89-xggx-qqh2
Aliases
Published
2022-05-24T17:17:14Z
Modified
2024-02-16T08:24:50.644170Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Improper permission checks in Jenkins Copy Artifact Plugin
Details

Copy Artifact Plugin 1.43.1 and earlier performs improper permission checks when determining whether a build can copy artifacts from another project build. This allows attackers, usually with Job/Configure permission, to configure jobs to copy artifacts from jobs they have no permission to access.

Copy Artifact Plugin 1.44 now properly performs permission checks when copying artifacts. When updating the plugin from a previous version, the previous behavior is retained (\"Migration mode\"). To enable the additional protections, switch to the new \"Production mode\". Doing so may cause existing jobs to fail to copy artifacts. For more information see the plugin documentation.

References

Affected packages

Maven / org.jenkins-ci.plugins:copyartifact

Package

Name
org.jenkins-ci.plugins:copyartifact
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/copyartifact

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.44

Affected versions

1.*

1.13
1.14
1.15
1.16
1.17
1.18
1.19
1.20
1.21
1.22
1.23
1.24
1.25
1.26
1.27
1.28
1.29
1.30
1.31
1.32
1.32.1
1.33
1.34
1.35
1.35.1
1.35.2
1.36
1.36.1
1.37
1.38
1.38.1
1.39
1.39.1
1.40-beta-1
1.40
1.41
1.42
1.42.1-beta-1
1.42.1
1.43
1.43.1

Database specific

{
    "last_known_affected_version_range": "<= 1.43.1"
}