GHSA-vvmr-8829-6whx

Suggest an improvement
Source
https://github.com/advisories/GHSA-vvmr-8829-6whx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/02/GHSA-vvmr-8829-6whx/GHSA-vvmr-8829-6whx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vvmr-8829-6whx
Aliases
Published
2022-02-01T00:46:57Z
Modified
2024-04-22T19:02:35.989168Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N CVSS Calculator
Summary
CSRF token missing in Symfony
Details

Description

The Symfony form component provides a CSRF protection mechanism by using a random token injected in the form and using the session to store and control the token submitted by the user. When using the FrameworkBundle, this protection can be enabled or disabled with the configuration. If the configuration is not specified, by default, the mechanism is enabled as long as the session is enabled.

In a recent change in the way the configuration is loaded, the default behavior has been dropped and, as a result, the CSRF protection is not enabled in form when not explicitly enabled, which makes the application sensible to CSRF attacks.

Resolution

Symfony restored the default configuration to enable the CSRF protection by default.

The patch for this issue is available here for branch 5.3.

Credits

We would like to thank Catalin Dan and David Lochner for reporting the issue and Jérémy Derussé for fixing the issue.

References

Affected packages

Packagist / symfony/framework-bundle

Package

Name
symfony/framework-bundle
Purl
pkg:composer/symfony/framework-bundle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.3.14
Fixed
5.3.15

Affected versions

5.*

5.3.14

v5.*

v5.3.14

Packagist / symfony/framework-bundle

Package

Name
symfony/framework-bundle
Purl
pkg:composer/symfony/framework-bundle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.4.3
Fixed
5.4.4

Affected versions

5.*

5.4.3

v5.*

v5.4.3

Packagist / symfony/framework-bundle

Package

Name
symfony/framework-bundle
Purl
pkg:composer/symfony/framework-bundle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0.3
Fixed
6.0.4

Affected versions

6.*

6.0.3

v6.*

v6.0.3