GHSA-vwr9-9f8v-vp5m

Suggest an improvement
Source
https://github.com/advisories/GHSA-vwr9-9f8v-vp5m
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-vwr9-9f8v-vp5m/GHSA-vwr9-9f8v-vp5m.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vwr9-9f8v-vp5m
Aliases
  • CVE-2012-5482
Published
2022-05-17T01:39:26Z
Modified
2024-01-12T20:56:35.278254Z
Summary
OpenStack Glance arbitrary deletion of non-protected images
Details

The v2 API in OpenStack Glance Grizzly, Folsom (2012.2), and Essex (2012.1) allows remote authenticated users to delete arbitrary non-protected images via an image deletion request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-4573.

References

Affected packages

PyPI / glance

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
11.0.0a0