GHSA-w358-rj93-r5qv

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-w358-rj93-r5qv/GHSA-w358-rj93-r5qv.json
Aliases
  • CVE-2021-27907
Published
2022-05-24T22:29:00Z
Modified
2022-06-22T18:32:09.678899Z
Details

Apache Superset up to and including 0.38.0 allowed the creation of a Markdown component on a Dashboard page for describing chart's related information. Abusing this functionality, a malicious user could inject javascript code executing unwanted action in the context of the user's browser. The javascript code will be automatically executed (Stored XSS) when a legitimate user surfs on the dashboard page. The vulnerability is exploitable creating a “div” section and embedding in it a “svg” element with javascript code.

References

Affected packages

PyPI / apache-superset

apache-superset

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
0.38.1

Affected versions

0.*

0.34.0
0.34.1
0.35.1
0.35.2
0.36.0
0.37.0
0.37.1
0.37.2
0.38.0

Database specific

{
    "last_known_affected_version_range": "<= 0.38.0"
}