GHSA-w4jq-qh47-hvjq

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/02/GHSA-w4jq-qh47-hvjq/GHSA-w4jq-qh47-hvjq.json
Aliases
  • CVE-2020-14338
Published
2022-02-15T01:37:41Z
Modified
2022-06-24T01:47:27.921035Z
Details

A flaw was found in Wildfly's implementation of Xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature. This flaw allows a specially-crafted XML file to manipulate the validation process in certain cases. This issue is the same flaw as CVE-2020-14621, which affected OpenJDK, and uses a similar code. All xerces jboss versions before 2.12.0.SP3.

References

Affected packages

Maven / xerces:xercesImpl

xerces:xercesImpl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
2.12.sp3

Affected versions

2.*

2.0.0
2.0.2
2.10.0
2.11.0
2.2.1
2.3.0
2.4.0
2.5.0
2.6.0
2.6.1
2.6.2
2.6.2-jaxb-1.0.6
2.7.1
2.8.0
2.8.1
2.9.0
2.9.1

Database specific

{
    "last_known_affected_version_range": "<= 2.12.sp2"
}