GHSA-w4q7-f34x-vpgc

Suggest an improvement
Source
https://github.com/advisories/GHSA-w4q7-f34x-vpgc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-w4q7-f34x-vpgc/GHSA-w4q7-f34x-vpgc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-w4q7-f34x-vpgc
Aliases
Published
2022-05-24T17:02:16Z
Modified
2024-04-29T10:28:08.379503Z
Severity
  • 5.7 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N CVSS Calculator
Summary
FreeIPA logs passwords embedded in commands in calls using batch
Details

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way that FreeIPA's batch processing API logged operations. This included passing user passwords in clear text on FreeIPA masters. Batch processing of commands with passwords as arguments or options is not performed by default in FreeIPA but is possible by third-party components. An attacker having access to system logs on FreeIPA masters could use this flaw to produce log file content with passwords exposed.

References

Affected packages

PyPI / freeipa

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.6.0
Fixed
4.6.7

Affected versions

4.*

4.6.1
4.6.2
4.6.3
4.6.4
4.6.5

PyPI / freeipa

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.7.0
Fixed
4.7.4

Affected versions

4.*

4.7.0
4.7.1
4.7.2

PyPI / freeipa

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.8.0
Fixed
4.8.3

Affected versions

4.*

4.8.0
4.8.1
4.8.2