GHSA-wchx-rm6h-7jf6

Suggest an improvement
Source
https://github.com/advisories/GHSA-wchx-rm6h-7jf6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/05/GHSA-wchx-rm6h-7jf6/GHSA-wchx-rm6h-7jf6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-wchx-rm6h-7jf6
Aliases
  • CVE-2024-30054
Published
2024-05-14T18:31:05Z
Modified
2024-05-19T02:24:45.246597Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Microsoft Power BI Client JavaScript SDK Information Disclosure Vulnerability
Details

Microsoft Power BI Client JavaScript SDK Information Disclosure Vulnerability

References

Affected packages

NuGet / Microsoft.PowerBI.JavaScript

Package

Name
Microsoft.PowerBI.JavaScript
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.PowerBI.JavaScript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
2.23.0

Affected versions

1.*

1.0.11-prevew
1.0.11-preview
1.0.12-preview
1.1.0

2.*

2.0.0
2.2.1
2.2.3
2.2.4
2.2.5
2.2.6
2.3.0
2.3.1
2.3.2
2.3.3
2.3.4
2.4.0
2.4.1
2.4.2
2.4.5
2.4.6
2.4.7
2.5.0
2.5.1
2.6.0
2.6.1
2.6.2
2.6.3
2.6.4
2.6.5
2.6.6
2.6.7
2.6.9
2.7.0
2.7.1
2.7.2
2.7.3
2.7.4
2.7.5
2.8.0
2.8.1
2.10.0
2.10.1
2.10.2
2.10.3
2.10.4
2.11.0
2.12.0
2.12.1
2.13.1.1
2.13.2
2.13.3
2.14.0
2.14.1
2.15.1
2.16.1
2.16.2
2.16.5
2.17.1
2.17.2
2.18.0
2.18.1
2.18.2
2.18.3
2.18.4
2.18.5
2.18.6
2.18.7
2.19.0
2.19.1
2.20.0
2.20.1
2.21.0
2.21.1
2.22.0
2.22.1
2.22.2
2.22.3
2.22.4
2.23.0