GHSA-wjvr-2hjg-6rhj

Suggest an improvement
Source
https://github.com/advisories/GHSA-wjvr-2hjg-6rhj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/03/GHSA-wjvr-2hjg-6rhj/GHSA-wjvr-2hjg-6rhj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-wjvr-2hjg-6rhj
Aliases
Published
2022-03-30T00:00:24Z
Modified
2024-02-16T08:13:16.384160Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
CSRF vulnerability in Proxmox Plugin
Details

A cross-site request forgery (CSRF) vulnerability in Jenkins Proxmox Plugin 0.7.0 and earlier allows attackers to connect to an attacker-specified host using attacker-specified username and password (perform a connection test), disable SSL/TLS validation for the entire Jenkins controller JVM as part of the connection test (see CVE-2022-28142), and test a rollback with attacker-specified parameters.

References

Affected packages

Maven / org.jenkins-ci.plugins:proxmox

Package

Name
org.jenkins-ci.plugins:proxmox
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/proxmox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.1

Affected versions

0.*

0.2
0.2.1
0.2.2
0.4.0
0.4.1
0.4.2
0.5.0
0.6.0
0.7.0

Database specific

{
    "last_known_affected_version_range": "<= 0.7.0"
}