GHSA-wqcc-qf63-c2x4

Suggest an improvement
Source
https://github.com/advisories/GHSA-wqcc-qf63-c2x4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/01/GHSA-wqcc-qf63-c2x4/GHSA-wqcc-qf63-c2x4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-wqcc-qf63-c2x4
Aliases
  • CVE-2023-49599
Published
2024-01-10T18:30:27Z
Modified
2024-02-16T08:18:52.946250Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
WWBN AVideo Insufficient Entropy vulnerbaility
Details

An insufficient entropy vulnerability exists in the salt generation functionality of WWBN AVideo dev master commit 15fed957fb. A specially crafted series of HTTP requests can lead to privilege escalation. An attacker can gather system information via HTTP requests and bruteforce the salt offline, leading to forging a legitimate password recovery code for the admin user.

References

Affected packages

Packagist / wwbn/avideo

Package

Name
wwbn/avideo
Purl
pkg:composer/wwbn/avideo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
12.4

Affected versions

10.*

10.4
10.8

Other

11

11.*

11.1
11.1.1
11.5
11.6

12.*

12.4