GHSA-wrqc-q8p5-76m5

Suggest an improvement
Source
https://github.com/advisories/GHSA-wrqc-q8p5-76m5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-wrqc-q8p5-76m5/GHSA-wrqc-q8p5-76m5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-wrqc-q8p5-76m5
Aliases
Published
2022-05-13T01:48:31Z
Modified
2024-02-16T08:20:57.565124Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Incorrect Authorization in Jenkins Gerrit Trigger Plugin
Details

An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.

References

Affected packages

Maven / com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger

Package

Name
com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
View open source insights on deps.dev
Purl
pkg:maven/com.sonyericsson.hudson.plugins.gerrit/gerrit-trigger

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.27.5

Affected versions

2.*

2.0
2.1.0
2.2.0
2.3.0
2.3.1
2.4.0
2.5.0
2.5.1
2.5.2
2.6.0
2.7.0
2.8.0
2.9.0
2.10.0
2.10.1
2.11.0-beta-1
2.11.0-beta-2
2.11.0-beta-3
2.11.0-beta-4
2.11.0
2.11.1
2.12.0-beta-1
2.12.0-beta-2
2.12.0-beta-3
2.12.0-beta-4
2.12.0-beta-5
2.12.0
2.13.0-beta-2
2.13.0-beta-3
2.13.0-beta-4
2.13.0-beta-5
2.13.0-beta-6
2.13.0
2.14.0-beta-1
2.14.0-beta-2
2.14.0-beta-3
2.14.0
2.15.0-beta-1
2.15.0
2.15.1
2.15.2
2.16.0
2.17.0
2.17.1
2.17.2
2.17.3
2.17.4
2.17.5
2.18.0
2.18.1
2.18.2
2.18.3
2.18.4
2.19.0
2.20.0
2.21.0
2.21.1
2.22.0-beta-1
2.22.0
2.23.0
2.23.1
2.23.2
2.23.3
2.24.0
2.25.0
2.26.0
2.26.1
2.26.2
2.27.0
2.27.1
2.27.2
2.27.3
2.27.4