GHSA-wv2f-3rxv-jqhp

Suggest an improvement
Source
https://github.com/advisories/GHSA-wv2f-3rxv-jqhp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/07/GHSA-wv2f-3rxv-jqhp/GHSA-wv2f-3rxv-jqhp.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-wv2f-3rxv-jqhp
Aliases
  • CVE-2018-3724
Published
2018-07-26T15:21:04Z
Modified
2023-11-08T04:00:17.365988Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Path Traversal in general-file-server
Details

All versions of general-file-server are vulnerable to path traversal.

Recommendation

No fix is currently available for this vulnerability. It is our recommendation to not use this module until a fix has been provided.

References

Affected packages

npm / general-file-server

Package

Name
general-file-server
View open source insights on deps.dev
Purl
pkg:npm/general-file-server

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.1.8