GHSA-x5cw-843f-r366

Suggest an improvement
Source
https://github.com/advisories/GHSA-x5cw-843f-r366
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/08/GHSA-x5cw-843f-r366/GHSA-x5cw-843f-r366.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-x5cw-843f-r366
Aliases
  • CVE-2022-25646
Published
2022-08-31T00:00:24Z
Modified
2023-11-08T04:08:47.591521Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
x-data-spreadsheet through 1.1.9 vulnerable to Cross-site Scripting
Details

All versions of package x-data-spreadsheet are vulnerable to Cross-site Scripting (XSS) due to missing sanitization of values inserted into the cells.

References

Affected packages

npm / x-data-spreadsheet

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.1.9