GHSA-x5rv-w9pm-8qp8

Suggest an improvement
Source
https://github.com/advisories/GHSA-x5rv-w9pm-8qp8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-x5rv-w9pm-8qp8/GHSA-x5rv-w9pm-8qp8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-x5rv-w9pm-8qp8
Aliases
  • CVE-2023-0092
Published
2023-03-01T19:17:17Z
Modified
2023-11-08T04:11:05.456526Z
Severity
  • 4.9 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Juju controller - Arbitrary file reading vulnerability
Details

Impact

An authenticated user who has read access to the juju controller model, may construct a remote request to download an arbitrary file from the controller's filesystem.

Patches

Patched in juju 2.9.38 and juju 3.0.3 juju/juju#ef803e2

Workarounds

Limit read access to the controller model to only trusted users.

References

Affected packages

Go / github.com/juju/juju

Package

Name
github.com/juju/juju
View open source insights on deps.dev
Purl
pkg:golang/github.com/juju/juju

Affected ranges

Type
SEMVER
Events
Introduced
2.9.22
Fixed
2.9.38

Go / github.com/juju/juju

Package

Name
github.com/juju/juju
View open source insights on deps.dev
Purl
pkg:golang/github.com/juju/juju

Affected ranges

Type
SEMVER
Events
Introduced
3.0.0
Fixed
3.0.3