GHSA-x5x7-3v85-wpc4

Suggest an improvement
Source
https://github.com/advisories/GHSA-x5x7-3v85-wpc4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/10/GHSA-x5x7-3v85-wpc4/GHSA-x5x7-3v85-wpc4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-x5x7-3v85-wpc4
Aliases
Published
2018-10-16T19:37:33Z
Modified
2024-02-19T05:32:27.835005Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Apache Struts allows entering a custom URL in a form field if built-in URLValidator is used
Details

In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. NOTE: this vulnerability exists because of an incomplete fix for S2-047 / CVE-2017-7672.

References

Affected packages

Maven / org.apache.struts:struts2-core

Package

Name
org.apache.struts:struts2-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.struts/struts2-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.3.7
Fixed
2.3.34

Affected versions

2.*

2.3.7
2.3.8
2.3.12
2.3.14
2.3.14.1
2.3.14.2
2.3.14.3
2.3.15
2.3.15.1
2.3.15.2
2.3.15.3
2.3.16
2.3.16.1
2.3.16.2
2.3.16.3
2.3.20
2.3.20.1
2.3.20.3
2.3.24
2.3.24.1
2.3.24.3
2.3.28
2.3.28.1
2.3.29
2.3.30
2.3.31
2.3.32
2.3.33

Database specific

{
    "last_known_affected_version_range": "<= 2.3.33"
}

Maven / org.apache.struts:struts2-core

Package

Name
org.apache.struts:struts2-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.struts/struts2-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.5.0
Fixed
2.5.13

Affected versions

2.*

2.5
2.5.1
2.5.2
2.5.5
2.5.8
2.5.10
2.5.10.1
2.5.12

Database specific

{
    "last_known_affected_version_range": "<= 2.5.12"
}