GHSA-x7w4-vfrh-fc3h

Suggest an improvement
Source
https://github.com/advisories/GHSA-x7w4-vfrh-fc3h
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-x7w4-vfrh-fc3h/GHSA-x7w4-vfrh-fc3h.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-x7w4-vfrh-fc3h
Aliases
Published
2022-07-28T00:00:42Z
Modified
2024-02-16T08:18:44.175196Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins Coverity Plugin allows attackers with Overall/Read permission to enumerate credentials IDs
Details

Jenkins Coverity Plugin 1.11.4 and earlier does not perform a permission check in an HTTP endpoint.

This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.

As of publication of this advisory, there is no fix.

References

Affected packages

Maven / org.jenkins-ci.plugins:coverity

Package

Name
org.jenkins-ci.plugins:coverity
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/coverity

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.11.4

Affected versions

1.*

1.0
1.1
1.1.1
1.1.2
1.1.3
1.1.4
1.1.5
1.2.0
1.2.1
1.2.2
1.2.3
1.2.4
1.2.5
1.2.6
1.2.7
1.3.0
1.3.1
1.4.0
1.4.1
1.5.0
1.5.1
1.5.2
1.6.0
1.7.0
1.7.1
1.7.2
1.7.3
1.8.0
1.8.1
1.9.0
1.9.1
1.9.2
1.10.0
1.11.0
1.11.1
1.11.2
1.11.3
1.11.4