GHSA-xgmh-rvpw-6498

Suggest an improvement
Source
https://github.com/advisories/GHSA-xgmh-rvpw-6498
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-xgmh-rvpw-6498/GHSA-xgmh-rvpw-6498.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-xgmh-rvpw-6498
Aliases
Published
2022-05-14T03:33:40Z
Modified
2024-01-30T23:41:35.248378Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Reflected cross-site-scripting vulnerability in report URL of Jenkins CppNCSS Plugin
Details

A cross-site scripting vulnerability exists in Jenkins CppNCSS Plugin 1.1 and earlier in AbstractProjectAction/index.jelly that allow an attacker to craft links to Jenkins URLs that run arbitrary JavaScript in the user's browser when accessed.

References

Affected packages

Maven / org.jenkins-ci.plugins:cppncss

Package

Name
org.jenkins-ci.plugins:cppncss
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/cppncss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2

Database specific

{
    "last_known_affected_version_range": "<= 1.1"
}