GHSA-xh3v-6f9j-wxw3

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/08/GHSA-xh3v-6f9j-wxw3/GHSA-xh3v-6f9j-wxw3.json
Aliases
  • CVE-2022-25275
Published
2022-08-06T05:31:26Z
Modified
2022-08-06T05:31:26Z
Details

In some situations, the Image module does not correctly check access to image files not stored in the standard public files directory when generating derivative images using the image styles system.

Access to a non-public file is checked only if it is stored in the "private" file system. However, some contributed modules provide additional file systems, or schemes, which may lead to this vulnerability.

This vulnerability is mitigated by the fact that it only applies when the site sets (Drupal 9) $config['image.settings']['allow_insecure_derivatives'] or (Drupal 7) $conf['image_allow_insecure_derivatives'] to TRUE. The recommended and default setting is FALSE, and Drupal core does not provide a way to change that in the admin UI.

Some sites may require configuration changes following this security release. Review the release notes for your Drupal version if you have issues accessing files or image styles after updating.

References

Affected packages

Packagist / drupal/core

drupal/core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0
Fixed
7.91

Affected versions

Packagist / drupal/core

drupal/core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
8.0.0
Fixed
9.3.19

Affected versions

Packagist / drupal/core

drupal/core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
9.4.0
Fixed
9.4.3

Affected versions