GHSA-xqqr-p362-6rmc

Suggest an improvement
Source
https://github.com/advisories/GHSA-xqqr-p362-6rmc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/11/GHSA-xqqr-p362-6rmc/GHSA-xqqr-p362-6rmc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-xqqr-p362-6rmc
Aliases
  • CVE-2017-16029
Published
2018-11-09T17:44:20Z
Modified
2023-11-08T03:59:00.558114Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Directory Traversal in hostr
Details

Affected versions of hostr are vulnerable to directory traversal which allows attackers to read files outside the current directory by sending ../ in the url path for GET requests.

Recommendation

Upgrade to version 2.3.6 or later.

References

Affected packages

npm / hostr

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.6

Database specific

{
    "last_known_affected_version_range": "<= 2.3.5"
}