GHSA-xr8f-59pp-rxxh

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-xr8f-59pp-rxxh/GHSA-xr8f-59pp-rxxh.json
Aliases
  • CVE-2019-1302
Published
2022-05-24T22:00:33Z
Modified
2022-09-22T04:02:09.561312Z
Details

An elevation of privilege vulnerability exists when a ASP.NET Core web application, created using vulnerable project templates, fails to properly sanitize web requests, aka 'ASP.NET Core Elevation Of Privilege Vulnerability'.

References

Affected packages

NuGet / Microsoft.AspNetCore.SpaServices

Microsoft.AspNetCore.SpaServices

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.2.0
Fixed
2.2.7

Affected versions

2.*

2.2.0

NuGet / Microsoft.AspNetCore.SpaServices

Microsoft.AspNetCore.SpaServices

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.0
Fixed
2.1.13

Affected versions

2.*

2.1.0
2.1.1