GHSA-xx77-w6p5-xvmj

Suggest an improvement
Source
https://github.com/advisories/GHSA-xx77-w6p5-xvmj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-xx77-w6p5-xvmj/GHSA-xx77-w6p5-xvmj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-xx77-w6p5-xvmj
Aliases
Published
2022-05-24T17:44:35Z
Modified
2024-02-16T08:23:54.319755Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
ShopXO RCE Vulnerability
Details

A remote command execution vulnerability in shopxo 1.9.3 allows an attacker to upload malicious code generated by phar where the suffix is JPG, which is uploaded after modifying the phar suffix.

References

Affected packages

Packagist / shopxo/shopxo

Package

Name
shopxo/shopxo
Purl
pkg:composer/shopxo/shopxo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.9.3

Affected versions

v1.*

v1.1.0
v1.2.0
v1.3.0
v1.4.0
v1.5.0
v1.6.0
v1.7.0
v1.8.0
v1.8.1
v1.9.0
v1.9.1
v1.9.2
v1.9.3