GHSA-xxv9-w5hm-328j

Suggest an improvement
Source
https://github.com/advisories/GHSA-xxv9-w5hm-328j
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/03/GHSA-xxv9-w5hm-328j/GHSA-xxv9-w5hm-328j.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-xxv9-w5hm-328j
Aliases
  • CVE-2024-28155
Published
2024-03-06T18:30:38Z
Modified
2024-05-02T14:26:50.992603Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins AppSpider Plugin missing permission checks
Details

Jenkins AppSpider Plugin 1.0.16 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to obtain information about available scan config names, engine group names, and client names.

References

Affected packages

Maven / com.rapid7:jenkinsci-appspider-plugin

Package

Name
com.rapid7:jenkinsci-appspider-plugin
View open source insights on deps.dev
Purl
pkg:maven/com.rapid7/jenkinsci-appspider-plugin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.17

Affected versions

1.*

1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.0.8
1.0.10
1.0.11
1.0.12
1.0.13
1.0.14
1.0.15
1.0.16