GO-2020-0020

Source
https://storage.googleapis.com/go-vulndb/ID/GO-2020-0020.json
Aliases
  • CVE-2017-20146
Published
2021-04-14T20:04:52Z
Modified
2022-08-19T22:21:47Z
Details

Usage of the CORS handler may apply improper CORS headers, allowing the requester to explicitly control the value of the Access-Control-Allow-Origin header, which bypasses the expected behavior of the Same Origin Policy.

References

Affected packages

Go / github.com/gorilla/handlers

github.com/gorilla/handlers

Affected ranges

Type
SEMVER
Events
Introduced
0
Fixed
1.3.0

Affected versions

Ecosystem specific

{
    "imports": [
        {
            "path": "github.com/gorilla/handlers",
            "symbols": [
                "cors.ServeHTTP"
            ]
        }
    ]
}

Database specific

{
    "url": "https://pkg.go.dev/vuln/GO-2020-0020"
}