GO-2023-1515

See a problem?
Source
https://pkg.go.dev/vuln/GO-2023-1515
Import Source
https://vuln.go.dev/ID/GO-2023-1515.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2023-1515
Aliases
Published
2023-02-14T16:19:12Z
Modified
2024-05-20T16:03:47Z
Summary
Denial of service when processing Git credentials in github.com/rancher/wrangler
Details

A denial of service (DoS) vulnerability exists in the Wrangler Git package. Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources.

This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.

A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.

References

Affected packages

Go / github.com/rancher/wrangler

Package

Name
github.com/rancher/wrangler
View open source insights on deps.dev
Purl
pkg:golang/github.com/rancher/wrangler

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.4-security1
Introduced
0.8.0
Fixed
0.8.5-security1
Introduced
0.8.6
Fixed
0.8.11
Introduced
1.0.0
Fixed
1.0.1

Ecosystem specific

{
    "imports": [
        {
            "path": "github.com/rancher/wrangler/pkg/git",
            "symbols": [
                "Git.Clone",
                "Git.Ensure",
                "Git.Head",
                "Git.LsRemote",
                "Git.Update",
                "Git.fetchAndReset",
                "Git.gitCmd",
                "Git.reset"
            ]
        }
    ]
}