GO-2023-2333

See a problem?
Source
https://pkg.go.dev/vuln/GO-2023-2333
Import Source
https://vuln.go.dev/ID/GO-2023-2333.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2023-2333
Aliases
Published
2023-11-15T19:07:55Z
Modified
2024-05-20T16:03:47Z
Summary
Range checker gadget allows wider inputs than allowed in github.com/consensys/gnark
Details

Range checker gadget allows wider inputs than allowed in github.com/consensys/gnark

References
Credits
    • @ultrainstinct30

Affected packages

Go / github.com/consensys/gnark

Package

Name
github.com/consensys/gnark
Purl
pkg:golang/github.com/consensys/gnark

Affected ranges

Type
SEMVER
Events
Introduced
0The exact introduced commit is unknown
Fixed
0.9.2-0.20231110170422-f528807119e9

Ecosystem specific

{
    "imports": [
        {
            "path": "github.com/consensys/gnark/std/rangecheck",
            "symbols": [
                "commitChecker.commit",
                "nbPLONKConstraints",
                "nbR1CSConstraints"
            ]
        }
    ]
}