GO-2024-2468

See a problem?
Source
https://pkg.go.dev/vuln/GO-2024-2468
Import Source
https://vuln.go.dev/ID/GO-2024-2468.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2024-2468
Aliases
Published
2024-06-05T15:10:52Z
Modified
2024-07-09T19:33:56Z
Summary
snapd Race Condition vulnerability in github.com/snapcore/snapd
Details

snapd Race Condition vulnerability in github.com/snapcore/snapd.

NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions.

(If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.)

The additional affected modules and versions are: github.com/snapcore/snapd before v2.57.6.

References

Affected packages

Go / github.com/snapcore/snapd

Package

Name
github.com/snapcore/snapd
View open source insights on deps.dev
Purl
pkg:golang/github.com/snapcore/snapd

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected

Ecosystem specific

{
    "custom_ranges": [
        {
            "events": [
                {
                    "introduced": "0"
                },
                {
                    "fixed": "2.57.6"
                }
            ],
            "type": "ECOSYSTEM"
        }
    ]
}