GO-2024-2481

See a problem?
Source
https://pkg.go.dev/vuln/GO-2024-2481
Import Source
https://vuln.go.dev/ID/GO-2024-2481.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2024-2481
Aliases
Published
2024-06-28T15:28:53Z
Modified
2024-07-09T19:33:56Z
Summary
Nginx-UI vulnerable to arbitrary file write through the Import Certificate feature in github.com/0xJacky/Nginx-UI
Details

Nginx-UI vulnerable to arbitrary file write through the Import Certificate feature in github.com/0xJacky/Nginx-UI.

NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions.

(If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.)

The additional affected modules and versions are: github.com/0xJacky/Nginx-UI before v2.0.0-beta.12.

References

Affected packages

Go / github.com/0xJacky/Nginx-UI

Package

Name
github.com/0xJacky/Nginx-UI
View open source insights on deps.dev
Purl
pkg:golang/github.com/0xJacky/Nginx-UI

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected

Ecosystem specific

{
    "custom_ranges": [
        {
            "events": [
                {
                    "introduced": "0"
                },
                {
                    "fixed": "2.0.0-beta.12"
                }
            ],
            "type": "ECOSYSTEM"
        }
    ]
}