GO-2024-2801

See a problem?
Source
https://pkg.go.dev/vuln/GO-2024-2801
Import Source
https://vuln.go.dev/ID/GO-2024-2801.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2024-2801
Aliases
Published
2024-06-10T16:39:03Z
Modified
2024-07-09T19:33:56Z
Summary
Calico privilege escalation vulnerability in github.com/projectcalico/calico
Details

Calico privilege escalation vulnerability in github.com/projectcalico/calico.

NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions.

(If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.)

The additional affected modules and versions are: github.com/projectcalico/calico before v3.26.5, from v3.27.0 before v3.27.3.

References

Affected packages

Go / github.com/projectcalico/calico

Package

Name
github.com/projectcalico/calico
View open source insights on deps.dev
Purl
pkg:golang/github.com/projectcalico/calico

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected

Ecosystem specific

{
    "custom_ranges": [
        {
            "events": [
                {
                    "introduced": "0"
                },
                {
                    "fixed": "3.26.5"
                },
                {
                    "introduced": "3.27.0"
                },
                {
                    "fixed": "3.27.3"
                }
            ],
            "type": "ECOSYSTEM"
        }
    ]
}