GO-2024-2968

See a problem?
Source
https://pkg.go.dev/vuln/GO-2024-2968
Import Source
https://vuln.go.dev/ID/GO-2024-2968.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2024-2968
Aliases
Published
2024-07-09T19:34:07Z
Modified
2024-07-09T19:59:28.156514Z
Summary
ZITADEL Vulnerable to Session Information Leakage in github.com/zitadel/zitadel
Details

ZITADEL Vulnerable to Session Information Leakage in github.com/zitadel/zitadel.

NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions.

(If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.)

The additional affected modules and versions are: github.com/zitadel/zitadel from v2.0.0 before v2.53.8, from v2.54.0 before v2.54.5, from v2.55.0 before v2.55.1.

References

Affected packages

Go / github.com/zitadel/zitadel

Package

Name
github.com/zitadel/zitadel
View open source insights on deps.dev
Purl
pkg:golang/github.com/zitadel/zitadel

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected

Ecosystem specific

{
    "custom_ranges": [
        {
            "events": [
                {
                    "introduced": "2.0.0"
                },
                {
                    "fixed": "2.53.8"
                },
                {
                    "introduced": "2.54.0"
                },
                {
                    "fixed": "2.54.5"
                },
                {
                    "introduced": "2.55.0"
                },
                {
                    "fixed": "2.55.1"
                }
            ],
            "type": "ECOSYSTEM"
        }
    ]
}