MAL-2023-514

See a problem?
Import Source
https://github.com/ossf/malicious-packages/blob/main/osv/malicious/npm/identity-management/MAL-2023-514.json
JSON Data
https://api.osv.dev/v1/vulns/MAL-2023-514
Aliases
  • GHSA-j944-pmph-q8qv
Published
2023-07-14T01:02:53Z
Modified
2023-11-08T04:20:29.308160Z
Summary
Malicious code in identity-management (npm)
Details

-= Per source details. Do not edit below this line.=-

Source: ghsa-malware (51996f6a2e2b1701e5670d8d169328ec0089179efef72ac9d2473f87ca47adf1)

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

References

Affected packages

npm / identity-management

Package

Name
identity-management
View open source insights on deps.dev
Purl
pkg:npm/identity-management

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected

Database specific

{
    "cwes": [
        {
            "description": "The product contains code that appears to be malicious in nature.",
            "cweId": "CWE-506",
            "name": "Embedded Malicious Code"
        }
    ]
}