MAL-2023-619

See a problem?
Import Source
https://github.com/ossf/malicious-packages/blob/main/osv/malicious/npm/network_security_private_communication_in_a_public_world_solution_manual_pdfzip_best__0sm/MAL-2023-619.json
JSON Data
https://api.osv.dev/v1/vulns/MAL-2023-619
Aliases
  • GHSA-3g8f-6v28-cmgv
Published
2023-05-09T00:00:21Z
Modified
2023-11-08T04:14:37.321032Z
Summary
Malicious code in network_security_private_communication_in_a_public_world_solution_manual_pdfzip_best__0sm (npm)
Details

-= Per source details. Do not edit below this line.=-

Source: ghsa-malware (410825b4c625b62e3df96687b1462d70f4fffda6f8a733399ad051d99c7dc696)

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

References

Affected packages

npm / network_security_private_communication_in_a_public_world_solution_manual_pdfzip_best__0sm

Package

Name
network_security_private_communication_in_a_public_world_solution_manual_pdfzip_best__0sm
View open source insights on deps.dev
Purl
pkg:npm/network_security_private_communication_in_a_public_world_solution_manual_pdfzip_best__0sm

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected

Database specific

{
    "cwes": [
        {
            "description": "The product contains code that appears to be malicious in nature.",
            "cweId": "CWE-506",
            "name": "Embedded Malicious Code"
        }
    ]
}