MAL-2024-1173

See a problem?
Import Source
https://github.com/ossf/malicious-packages/blob/main/osv/malicious/npm/google-requests/MAL-2024-1173.json
JSON Data
https://api.osv.dev/v1/vulns/MAL-2024-1173
Published
2024-03-27T01:15:59Z
Modified
2024-03-27T01:15:59Z
Summary
Malicious code in google-requests (npm)
Details

-= Per source details. Do not edit below this line.=-

Source: ossf-package-analysis (1f65c90bd401794ac768545381277a23159e66aa5b42a5ea05a38780fbcd691a)

The OpenSSF Package Analysis project identified 'google-requests' @ 99.2.0 (npm) as malicious.

It is considered malicious because:

  • The package communicates with a domain associated with malicious activity.

  • The package executes one or more commands associated with malicious behavior.

References
Credits

Affected packages

npm / google-requests

Package

Affected ranges

Affected versions

99.*

99.2.0