PYSEC-2023-242

Import Source
https://github.com/pypa/advisory-database/blob/main/vulns/httpie/PYSEC-2023-242.yaml
Aliases
Published
2023-11-16T18:15:00Z
Modified
2023-11-22T03:11:27.505283Z
Details

Missing SSL certificate validation in HTTPie v3.2.2 allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack.

References

Affected packages

PyPI / httpie

Package

Name
httpie

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown

Affected versions

0.*

0.1
0.1.1
0.1.2
0.1.3
0.1.4
0.1.5
0.1.6
0.2.0
0.2.1
0.2.2
0.2.3
0.2.4dev
0.2.4
0.2.5
0.2.6
0.2.7
0.3.0
0.3.1
0.4.0
0.4.1
0.5.0
0.5.1
0.6.0
0.7.0
0.7.2
0.8.0
0.9.0
0.9.1
0.9.2
0.9.3
0.9.4
0.9.5
0.9.6
0.9.7
0.9.8
0.9.9

1.*

1.0.0
1.0.2
1.0.3

2.*

2.0.0
2.1.0
2.2.0
2.3.0
2.4.0
2.5.0
2.6.0

3.*

3.0.0
3.0.1
3.0.2
3.1.0
3.2.0
3.2.1
3.2.2