PYSEC-2024-28

Import Source
https://github.com/pypa/advisory-database/blob/main/vulns/django/PYSEC-2024-28.yaml
Aliases
Published
2024-02-06T22:16:00Z
Modified
2024-02-16T08:26:32.550177Z
Details

An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. The intcomma template filter was subject to a potential denial-of-service attack when used with very long strings.

References

Affected packages

PyPI / django

Package

Name
django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.2
Fixed
3.2.24
Introduced
4.2
Fixed
4.2.10
Introduced
5.0
Fixed
5.0.2

Affected versions

3.*

3.2
3.2.1
3.2.2
3.2.3
3.2.4
3.2.5
3.2.6
3.2.7
3.2.8
3.2.9
3.2.10
3.2.11
3.2.12
3.2.13
3.2.14
3.2.15
3.2.16
3.2.17
3.2.18
3.2.19
3.2.20
3.2.21
3.2.22
3.2.23

4.*

4.2
4.2.1
4.2.2
4.2.3
4.2.4
4.2.5
4.2.6
4.2.7
4.2.8
4.2.9

5.*

5.0
5.0.1