PYSEC-2024-37

Import Source
https://github.com/pypa/advisory-database/blob/main/vulns/nonebot2/PYSEC-2024-37.yaml
Aliases
Published
2024-02-09T23:15:00Z
Modified
2024-02-16T16:41:43.954924Z
Details

nonebot2 is a cross-platform Python asynchronous chatbot framework written in Python. This security advisory pertains to a potential information leak (e.g., environment variables) in instances where developers utilize MessageTemplate and incorporate user-provided data into templates. The identified vulnerability has been remedied in pull request #2509 and will be included in versions released from 2.2.0. Users are strongly advised to upgrade to these patched versions to safeguard against the vulnerability. A temporary workaround involves filtering underscores before incorporating user input into the message template.

References

Affected packages

PyPI / nonebot2

Package

Name
nonebot2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.1
Fixed
2.2.0

Affected versions

2.*

2.0.1
2.1.0
2.1.1
2.1.2
2.1.3