RLSA-2024:0675

Import Source
https://storage.googleapis.com/resf-osv-data/RLSA-2024:0675.json
Related
  • CVE-2023-44441
  • CVE-2023-44442
  • CVE-2023-44443
  • CVE-2023-44444
Published
2024-05-10T14:32:42.380544Z
Modified
2024-05-10T14:34:23.795696Z
Summary
Important: gimp security update
Details

The GIMP (GNU Image Manipulation Program) is an image composition and editing program. GIMP provides a large image manipulation toolbox, including channel operations and layers, effects, sub-pixel imaging and anti-aliasing, and conversions, all with multi-level undo.

Security Fix(es):

  • gimp: dds buffer overflow RCE (CVE-2023-44441)

  • gimp: PSD buffer overflow RCE (CVE-2023-44442)

  • gimp: psp integer overflow RCE (CVE-2023-44443)

  • gimp: psp off-by-one RCE (CVE-2023-44444)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

Rocky Linux:9 / gimp

Package

Name
gimp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
2:2.99.8-4.el9_3