RLSA-2024:4050

See a problem?
Import Source
https://storage.googleapis.com/resf-osv-data/RLSA-2024:4050.json
JSON Data
https://api.osv.dev/v1/vulns/RLSA-2024:4050
Related
Published
2024-07-02T14:11:35.145045Z
Modified
2024-07-02T14:13:10.879269Z
Summary
Moderate: libreswan security update
Details

Libreswan is an implementation of IPsec and IKE for Linux. IPsec is the Internet Protocol Security and uses strong cryptography to provide both authentication and encryption services. These services allow you to build secure tunnels through untrusted networks such as virtual private network (VPN).

Security Fix(es):

  • libreswan: IKEv1 default AH/ESP responder can crash and restart (CVE-2024-3652)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References
Credits
    • Rocky Enterprise Software Foundation
    • Red Hat

Affected packages

Rocky Linux:9 / libreswan

Package

Name
libreswan
Purl
pkg:rpm/rocky-linux/libreswan?distro=rocky-linux-9&epoch=0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0:4.12-2.el9_4.1