RUSTSEC-2022-0037

Source
https://github.com/rustsec/advisory-db/blob/osv/crates/RUSTSEC-2022-0037.json
Aliases
Published
2022-07-21T12:00:00Z
Modified
2022-08-06T06:41:24Z
Details

Deeply nested fragments in a GraphQL request may cause a stack overflow in the server.

References

Affected packages

crates.io / async-graphql

async-graphql

Affected ranges

Type
SEMVER
Events
Introduced
0.0.0-0
Fixed
4.0.6

Affected versions

Ecosystem specific

{
    "affects": {
        "arch": [],
        "os": [],
        "functions": []
    }
}

Database specific

{
    "cvss": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H",
    "informational": null,
    "categories": [
        "denial-of-service"
    ]
}