UBUNTU-CVE-2026-33328

Source
https://ubuntu.com/security/CVE-2026-33328
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33328.json
JSON Data
https://api.osv.dev/v1/vulns/UBUNTU-CVE-2026-33328
Upstream
Downstream
Related
Published
2026-07-20T17:17:00Z
Modified
2026-11-04T03:30:22Z
Severity
  • 6.8 (Medium) CVSS_V4 - CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CVSS Calculator
  • 5.5 (Medium) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
  • Ubuntu - medium
Summary
[none]
Details

libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the gifload operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.

References

Affected packages

Ubuntu:Pro:24.04:LTS / vips

Package

Name
vips
Purl
pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fnoble

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
8.15.1-1.1ubuntu0.1~esm2

Affected versions

8.*
8.14.3-1
8.14.5-1
8.15.0-1
8.15.0-2
8.15.1-1
8.15.1-1build1
8.15.1-1.1build3
8.15.1-1.1build4
8.15.1-1.1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "binary_name": "gir1.2-vips-8.0",
            "binary_version": "8.15.1-1.1ubuntu0.1~esm2"
        },
        {
            "binary_name": "libvips-tools",
            "binary_version": "8.15.1-1.1ubuntu0.1~esm2"
        },
        {
            "binary_name": "libvips42t64",
            "binary_version": "8.15.1-1.1ubuntu0.1~esm2"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33328.json"

Ubuntu:Pro:26.04:LTS / vips

Package

Name
vips
Purl
pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fresolute

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
8.18.0-1ubuntu0.1~esm2

Affected versions

8.*
8.16.1-1
8.16.1-2
8.17.3-2
8.18.0-1
8.18.0-1build1
8.18.0-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "binary_name": "gir1.2-vips-8.0",
            "binary_version": "8.18.0-1ubuntu0.1~esm2"
        },
        {
            "binary_name": "libvips-tools",
            "binary_version": "8.18.0-1ubuntu0.1~esm2"
        },
        {
            "binary_name": "libvips42t64",
            "binary_version": "8.18.0-1ubuntu0.1~esm2"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33328.json"