UBUNTU-CVE-2026-73260

Source
https://ubuntu.com/security/CVE-2026-73260
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-73260.json
JSON Data
https://api.osv.dev/v1/vulns/UBUNTU-CVE-2026-73260
Upstream
Published
2026-10-14T19:17:00Z
Modified
2026-10-28T20:17:48Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
  • Ubuntu - medium
Summary
[none]
Details

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.

References

Affected packages

Ubuntu:26.10 / mongoose

Package

Name
mongoose
Purl
pkg:deb/ubuntu/mongoose?arch=source&distro=stonking

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

7.*
7.21+ds-1
7.21+ds-2
7.22+ds-1
7.23+ds-1

Ecosystem specific

{
    "binaries": [
        {
            "binary_name": "mongoose-webserver-source",
            "binary_version": "7.23+ds-1"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-73260.json"