UBUNTU-CVE-2026-77635

Source
https://ubuntu.com/security/CVE-2026-77635
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-77635.json
JSON Data
https://api.osv.dev/v1/vulns/UBUNTU-CVE-2026-77635
Upstream
Published
2026-08-24T21:17:00Z
Modified
2026-11-03T21:20:43Z
Severity
  • 9.2 (Critical) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N CVSS Calculator
  • Ubuntu - medium
Summary
[none]
Details

CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

References

Affected packages

Ubuntu:Pro:16.04:LTS / cakephp

Package

Name
cakephp
Purl
pkg:deb/ubuntu/cakephp?arch=source&distro=esm-apps-legacy%2Fxenial

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

2.*
2.7.2-1
2.8.0-1
2.8.0-1ubuntu0.1~esm1

Ecosystem specific

{
    "binaries": [
        {
            "binary_name": "cakephp",
            "binary_version": "2.8.0-1ubuntu0.1~esm1"
        },
        {
            "binary_name": "cakephp-scripts",
            "binary_version": "2.8.0-1ubuntu0.1~esm1"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-77635.json"

Ubuntu:20.04:LTS / cakephp

Package

Name
cakephp
Purl
pkg:deb/ubuntu/cakephp?arch=source&distro=focal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

2.*
2.10.11-2

Ecosystem specific

{
    "binaries": [
        {
            "binary_name": "cakephp",
            "binary_version": "2.10.11-2"
        },
        {
            "binary_name": "cakephp-scripts",
            "binary_version": "2.10.11-2"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-77635.json"

Ubuntu:22.04:LTS / cakephp

Package

Name
cakephp
Purl
pkg:deb/ubuntu/cakephp?arch=source&distro=jammy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

2.*
2.10.11-2.1
2.10.24-1

Ecosystem specific

{
    "binaries": [
        {
            "binary_name": "cakephp",
            "binary_version": "2.10.24-1"
        },
        {
            "binary_name": "cakephp-scripts",
            "binary_version": "2.10.24-1"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-77635.json"