UBUNTU-CVE-2026-83525

Source
https://ubuntu.com/security/CVE-2026-83525
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-83525.json
JSON Data
https://api.osv.dev/v1/vulns/UBUNTU-CVE-2026-83525
Upstream
Published
2026-10-29T00:00:00Z
Modified
2026-10-29T20:03:22Z
Severity
  • Ubuntu - medium
Summary
[none]
Details

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

References

Affected packages

Ubuntu:Pro:18.04:LTS / kafka

Package

Name
kafka
Purl
pkg:deb/ubuntu/kafka?arch=source&distro=esm-apps%2Fbionic

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

2.*
2.2.0u2-0ubuntu3.1
2.2.0u2-0ubuntu3.2
2.2.2u1-0ubuntu1+esm2

Ecosystem specific

{
    "binaries":  [
        {
            "binary_name":  "kafka",
            "binary_version":  "2.2.2u1-0ubuntu1+esm2"
        }
    ]
}

Database specific

source
"https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-83525.json"