USN-5378-3

See a problem?
Source
https://ubuntu.com/security/notices/USN-5378-3
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5378-3.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5378-3
Related
Published
2022-04-13T14:47:08.662762Z
Modified
2022-04-13T14:47:08.662762Z
Summary
xz-utils vulnerability
Details

USN-5378-2 fixed a vulnerability in XZ Utils. This update provides the corresponding update for Ubuntu 14.04 ESM and 16.04 ESM.

Original advisory details:

Cleemy Desu Wayo discovered that Gzip incorrectly handled certain filenames. If a user or automated system were tricked into performing zgrep operations with specially crafted filenames, a remote attacker could overwrite arbitrary files.

References

Affected packages

Ubuntu:Pro:14.04:LTS / xz-utils

Package

Name
xz-utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "liblzma5": "5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1",
            "xzdec": "5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1",
            "liblzma-doc": "5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1",
            "xz-utils": "5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1",
            "liblzma-dev": "5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / xz-utils

Package

Name
xz-utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "liblzma5": "5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1",
            "xzdec": "5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1",
            "liblzma-doc": "5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1",
            "xz-utils": "5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1",
            "liblzma-dev": "5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1"
        }
    ]
}