USN-6305-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6305-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6305-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6305-1
Related
Published
2023-08-23T16:40:19.026774Z
Modified
2023-08-23T16:40:19.026774Z
Summary
php8.1 vulnerabilities
Details

It was discovered that PHP incorrectly handled certain XML files. An attacker could possibly use this issue to expose sensitive information. (CVE-2023-3823)

It was discovered that PHP incorrectly handled certain PHAR files. An attacker could possibly use this issue to cause a crash, expose sensitive information or execute arbitrary code. (CVE-2023-3824)

References

Affected packages

Ubuntu:22.04:LTS / php8.1

Package

Name
php8.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.1.2-1ubuntu2.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php8.1-pgsql": "8.1.2-1ubuntu2.14",
            "php8.1-bcmath": "8.1.2-1ubuntu2.14",
            "php8.1": "8.1.2-1ubuntu2.14",
            "libapache2-mod-php8.1": "8.1.2-1ubuntu2.14",
            "php8.1-xml": "8.1.2-1ubuntu2.14",
            "php8.1-cgi": "8.1.2-1ubuntu2.14",
            "php8.1-common": "8.1.2-1ubuntu2.14",
            "libphp8.1-embed": "8.1.2-1ubuntu2.14",
            "php8.1-tidy": "8.1.2-1ubuntu2.14",
            "php8.1-sybase": "8.1.2-1ubuntu2.14",
            "php8.1-dev": "8.1.2-1ubuntu2.14",
            "php8.1-ldap": "8.1.2-1ubuntu2.14",
            "php8.1-snmp": "8.1.2-1ubuntu2.14",
            "php8.1-gmp": "8.1.2-1ubuntu2.14",
            "php8.1-curl": "8.1.2-1ubuntu2.14",
            "php8.1-cli": "8.1.2-1ubuntu2.14",
            "php8.1-fpm": "8.1.2-1ubuntu2.14",
            "php8.1-mysql": "8.1.2-1ubuntu2.14",
            "php8.1-interbase": "8.1.2-1ubuntu2.14",
            "php8.1-gd": "8.1.2-1ubuntu2.14",
            "php8.1-enchant": "8.1.2-1ubuntu2.14",
            "php8.1-bz2": "8.1.2-1ubuntu2.14",
            "php8.1-dba": "8.1.2-1ubuntu2.14",
            "php8.1-readline": "8.1.2-1ubuntu2.14",
            "php8.1-xsl": "8.1.2-1ubuntu2.14",
            "php8.1-odbc": "8.1.2-1ubuntu2.14",
            "php8.1-zip": "8.1.2-1ubuntu2.14",
            "php8.1-imap": "8.1.2-1ubuntu2.14",
            "php8.1-phpdbg": "8.1.2-1ubuntu2.14",
            "libapache2-mod-php8.0": "8.1.2-1ubuntu2.14",
            "php8.1-opcache": "8.1.2-1ubuntu2.14",
            "php8.1-sqlite3": "8.1.2-1ubuntu2.14",
            "libapache2-mod-php7.4": "8.1.2-1ubuntu2.14",
            "php8.1-pspell": "8.1.2-1ubuntu2.14",
            "php8.1-intl": "8.1.2-1ubuntu2.14",
            "php8.1-mbstring": "8.1.2-1ubuntu2.14",
            "php8.1-soap": "8.1.2-1ubuntu2.14"
        }
    ]
}