USN-6771-1

Source
https://ubuntu.com/security/notices/USN-6771-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6771-1.json
Related
Published
2024-05-13T13:14:04.325505Z
Modified
2024-05-13T13:14:04.325505Z
Summary
sqlparse vulnerability
Details

It was discovered that SQL parse incorrectly handled certain nested lists. An attacker could possibly use this issue to cause a denial of service.

References

Affected packages

Ubuntu:22.04:LTS / sqlparse

Package

Name
sqlparse

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
0.4.2-1ubuntu0.22.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-sqlparse": "0.4.2-1ubuntu0.22.04.2",
            "python-sqlparse-doc": "0.4.2-1ubuntu0.22.04.2",
            "sqlformat": "0.4.2-1ubuntu0.22.04.2"
        }
    ]
}

Ubuntu:23.10 / sqlparse

Package

Name
sqlparse

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
0.4.2-1ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-sqlparse": "0.4.2-1ubuntu1.1",
            "python-sqlparse-doc": "0.4.2-1ubuntu1.1",
            "sqlformat": "0.4.2-1ubuntu1.1"
        }
    ]
}

Ubuntu:24.04:LTS / sqlparse

Package

Name
sqlparse

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
0.4.4-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-sqlparse": "0.4.4-1ubuntu0.1",
            "python-sqlparse-doc": "0.4.4-1ubuntu0.1",
            "sqlformat": "0.4.4-1ubuntu0.1"
        }
    ]
}