USN-6833-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6833-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6833-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6833-1
Related
Published
2024-06-13T12:35:18.732083Z
Modified
2024-06-13T12:35:18.732083Z
Summary
vte2.91 vulnerability
Details

Siddharth Dushantha discovered that VTE incorrectly handled large window resize escape sequences. An attacker could possibly use this issue to consume resources, leading to a denial of service.

References

Affected packages

Ubuntu:20.04:LTS / vte2.91

Package

Name
vte2.91

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.60.3-0ubuntu1~20.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-vte-2.91": "0.60.3-0ubuntu1~20.5",
            "libvte-2.91-0": "0.60.3-0ubuntu1~20.5",
            "libvte-2.91-doc": "0.60.3-0ubuntu1~20.5",
            "libvte-2.91-dev": "0.60.3-0ubuntu1~20.5",
            "libvte-2.91-common": "0.60.3-0ubuntu1~20.5"
        }
    ]
}

Ubuntu:22.04:LTS / vte2.91

Package

Name
vte2.91

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.68.0-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-vte-2.91": "0.68.0-1ubuntu0.1",
            "libvte-2.91-0": "0.68.0-1ubuntu0.1",
            "libvte-2.91-doc": "0.68.0-1ubuntu0.1",
            "libvte-2.91-dev": "0.68.0-1ubuntu0.1",
            "libvte-2.91-common": "0.68.0-1ubuntu0.1"
        }
    ]
}

Ubuntu:23.10 / vte2.91

Package

Name
vte2.91

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.74.0-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-vte-2.91": "0.74.0-2ubuntu0.1",
            "libvte-2.91-gtk4-0": "0.74.0-2ubuntu0.1",
            "libvte-2.91-gtk4-doc": "0.74.0-2ubuntu0.1",
            "libvte-2.91-dev": "0.74.0-2ubuntu0.1",
            "gir1.2-vte-3.91": "0.74.0-2ubuntu0.1",
            "libvte-2.91-common": "0.74.0-2ubuntu0.1",
            "libvte-2.91-0": "0.74.0-2ubuntu0.1",
            "libvte-2.91-doc": "0.74.0-2ubuntu0.1",
            "libvte-2.91-gtk4-dev": "0.74.0-2ubuntu0.1"
        }
    ]
}

Ubuntu:24.04:LTS / vte2.91

Package

Name
vte2.91

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.76.0-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-vte-2.91": "0.76.0-1ubuntu0.1",
            "libvte-2.91-gtk4-0": "0.76.0-1ubuntu0.1",
            "libvte-2.91-gtk4-doc": "0.76.0-1ubuntu0.1",
            "libvte-2.91-dev": "0.76.0-1ubuntu0.1",
            "gir1.2-vte-3.91": "0.76.0-1ubuntu0.1",
            "libvte-2.91-common": "0.76.0-1ubuntu0.1",
            "libvte-2.91-0": "0.76.0-1ubuntu0.1",
            "libvte-2.91-doc": "0.76.0-1ubuntu0.1",
            "libvte-2.91-gtk4-dev": "0.76.0-1ubuntu0.1"
        }
    ]
}