USN-6845-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6845-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6845-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6845-1
Related
Published
2024-06-24T10:08:06.448315Z
Modified
2024-06-24T10:08:06.448315Z
Summary
libhibernate3-java vulnerability
Details

It was discovered that Hibernate incorrectly handled certain inputs with unsanitized literals. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to obtain sensitive information.

References

Affected packages

Ubuntu:Pro:18.04:LTS / libhibernate3-java

Package

Name
libhibernate3-java

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.6.10.Final-9ubuntu0.18.04.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libhibernate3-java": "3.6.10.Final-9ubuntu0.18.04.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / libhibernate3-java

Package

Name
libhibernate3-java

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.6.10.Final-9+deb10u1build0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libhibernate3-java": "3.6.10.Final-9+deb10u1build0.20.04.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libhibernate3-java

Package

Name
libhibernate3-java

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.6.10.Final-4ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libhibernate3-java-doc": "3.6.10.Final-4ubuntu0.1~esm1",
            "libhibernate3-java": "3.6.10.Final-4ubuntu0.1~esm1"
        }
    ]
}