USN-6853-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6853-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6853-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6853-1
Related
Published
2024-06-26T12:27:29.717655Z
Modified
2024-06-26T12:27:29.717655Z
Summary
ruby2.7, ruby3.0, ruby3.1 vulnerability
Details

It was discovered that Ruby incorrectly handled the ungetbyte and ungetc methods. A remote attacker could use this issue to cause Ruby to crash, resulting in a denial of service, or possibly obtain sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / ruby2.7

Package

Name
ruby2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.0-5ubuntu1.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.7-doc": "2.7.0-5ubuntu1.14",
            "ruby2.7": "2.7.0-5ubuntu1.14",
            "libruby2.7": "2.7.0-5ubuntu1.14",
            "ruby2.7-dev": "2.7.0-5ubuntu1.14"
        }
    ]
}

Ubuntu:22.04:LTS / ruby3.0

Package

Name
ruby3.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.2-7ubuntu2.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby3.0-dev": "3.0.2-7ubuntu2.7",
            "ruby3.0": "3.0.2-7ubuntu2.7",
            "ruby3.0-doc": "3.0.2-7ubuntu2.7",
            "libruby3.0": "3.0.2-7ubuntu2.7"
        }
    ]
}

Ubuntu:23.10 / ruby3.1

Package

Name
ruby3.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.2-7ubuntu3.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby3.1-dev": "3.1.2-7ubuntu3.3",
            "ruby3.1-doc": "3.1.2-7ubuntu3.3",
            "libruby3.1": "3.1.2-7ubuntu3.3",
            "ruby3.1": "3.1.2-7ubuntu3.3"
        }
    ]
}